Jump to content
Moopler
  • 0
Sign in to follow this  
lapeiro

Can anyone help me updating these scripts?

Question

// Item Vac Char Position

[ENABLE]
Alloc(Hook,128)
label(DoItemVac)
registersymbol(ItemVac_X)
alloc(ItemVac_X,8)
registersymbol(ItemVac_Y)
alloc(ItemVac_Y,8)
registersymbol(Save)
alloc(Save, 2)
ItemVac_X:
dd #00000000
ItemVac_Y:
dd #00000000
Save:
db 01
00992124: //E8 ? ? ? ? 8B C8 8B ? 24 0C
jmp Hook
Hook:
cmp [Save], 01
jne DoItemVac
mov [Save], 00
DoItemVac:
push eax
push ecx
mov eax, [01A9E748] //A1 ?? ?? ?? ?? 85 C0 75 ?? 5F C3 8D 48
mov ecx, [eax+B724]
mov [ItemVac_X], ecx
mov ecx, [eax+B728]
mov [ItemVac_Y], ecx
pop ecx
pop eax
call 004925F0
mov ecx,eax
mov eax,[esp+0C]
push ecx
mov ecx, [ItemVac_X]
mov [eax],ecx
mov ecx, [ItemVac_Y]
mov [eax+04],ecx
pop ecx
pop edi
pop esi
ret 0004

[DISABLE]
dealloc(ItemVac_X)
dealloc(ItemVac_Y)
dealloc(Save)
dealloc(Hook)
unregistersymbol(ItemVac_X)
unregistersymbol(ItemVac_Y)
unregistersymbol(Save)
00992124:
call 004925F0

and

// BWFMA
[enable]
alloc(find_hit_mob_in_rect_hook,128)

alloc(try_doing_blazewiz_attack_hook,128)
label(try_doing_blazewiz_attack_return)


alloc(set_mob_pos,4)
registersymbol(set_mob_pos)

set_mob_pos:
dd 00000000


007FF4DD: //E8 ? ? ? ? 8B 4E 04 8B ? 8B 50 0c
jmp try_doing_blazewiz_attack_hook
try_doing_blazewiz_attack_return:

try_doing_blazewiz_attack_hook:
mov [set_mob_pos],00000001
call 012D68B0
mov [set_mob_pos],00000000
jmp try_doing_blazewiz_attack_return

007F4685: //E8 ? ? ? ? 8B F8 89 7C 24 10 85 FF 0F
call find_hit_mob_in_rect_hook

find_hit_mob_in_rect_hook:
mov eax,[01AA2D1C] // A1 ? ? ? ? 8B ? ? 8B ? ? 8B ? ? 8B ? ? 83
lea eax,[eax+1C]
mov [esp+04],eax
jmp 009E8CE0

[disable]

007FF4DD:
call 012D68B0

007F4685:
call 009E8CE0

unregistersymbol(set_mob_pos)
dealloc(set_mob_pos)

dealloc(try_doing_blazewiz_attack_hook)
dealloc(find_hit_mob_in_rect_hook)

the item vac, vacs the items to a position ( not char though ) and whenever i tick the BW FMA i stop being able to hit mobs , could anyone tell me what i need to fix here please?

Edited by lapeiro
item vac was wrong

Share this post


Link to post

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×