Jump to content
Moopler
  • 0
Sign in to follow this  
CZNT

Question How do I update scripts that contains CUserLocal in it?

Question

Hello there Moopler community, i'm new in hacking and editing scripts, i have some problems trying to update some scripts specially some that contains (CUserLocal)
when i search for AOB i get this

9CGs8Ol.png

this value is the same than the 180.2 version of the script

Spoiler

[enable]
alloc(Aggro,128)
label(return)

Aggro:
mov eax,[029E6028] // CUserLocal: 8B 3D ? ? ? ? 8B 40
lea eax,[eax+04]
mov [ecx+438+08],eax // Aggro Offset: 83 ? ? ? ? ? ? 0F 85 ? ? ? ? 8B ? ? 8B ? ? 8D ? ? FF D0 [Offset+0x08]

push ebp
mov ebp,esp
and esp,-40
jmp return

01E07E20: // CVecCtrlMob::WorkUpdateActive
jmp Aggro
nop
return:

[disable]
01E07E20: // 55 8B EC 83 E4 ? 6A ? 68 ? ? ? ? 64 A1 ? ? ? ? 50 83 EC ? 53 56 57 A1 ? ? ? ? 33 C4 50 8D 44 24 ? 64 A3 ? ? ? ? 8B F1 8B 4D ? 8B 06
push ebp
mov ebp,esp
and esp,-40

dealloc(Aggro)

Checking the updated script posted by @OuterHaven i can see a different value

mov eax,[029E5A68] // CUserLocal: 8B 3D ? ? ? ? 8B 40

Instead of 
 

mov eax,[029E6028] // CUserLocal: 8B 3D ? ? ? ? 8B 40


so, my question is: What I'm doing wrong ?

Edited by CZNT

Share this post


Link to post

4 answers to this question

Recommended Posts

  • 0
5 minutes ago, OuterHaven said:

If thats what you scan then its correct

but in other scripts (i.e Air Hit Mob Vac) you use 029E5A68 and works very well (i'm not a vac user, but i activate the script for some mins, then attack, loot and it looks good without crash or DC) 

EDIT: havent tested with the other value.

Edited by CZNT

Share this post


Link to post
  • 0
11 minutes ago, OuterHaven said:

If you are referring to the old thread that isn't updated/put into the script library yet. Not sure why the old value still work 

you're right some values from 180.2 still work :DxD

Share this post


Link to post
  • -1

If you are referring to the old thread that isn't updated/put into the script library yet. Not sure why the old value still work 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×